Script Path Problem Finder

I installed the scripts from Mekkablu and I ran the script ‘Path’ > ‘Path Problem Finder’ but it does not open a new tab. Does this mean I do not have any glyphs path problems?

The reason I am asking is because I am trying to upload a font to Monotype and am receiving an error message ‘Glyph contours have correct winding directions’. I tried selecting all glyphs > 'Paths > Correct path directions 'but this didn’t fix it.

If it finds no problems, it will display a floating notification like this:

But it sounds like the script ran into an error. Take a look into the Macro Window (Window > Macro Panel), there ought to be an error message there.

The macro panel says the following

Start
Traceback (most recent call last):
File “Path Problem Finder.py”, line 8, in
import vanilla, math
ImportError: No module named vanilla
End

That means you need to install the modules first: Click on Glyphs > Preferences > Addons > Modules > Install Modules and wait until the cursor stops spinning. Then try again.

It says ‘Could not load the modules.’

I added all the files from the zip file to the Script folder ~/Library/Application Support/Glyphs/Scripts/

I restarted Glyphs, I restarted my Mac but I still cannot load the modules.

By ‘Glyphs > Preferences > Addons > Modules > Install Modules’, I meant:

  1. Choose Glyphs > Preferences:
    image
  2. Click on Addons.
  3. Click on Modules.
  4. Click on Install Modules.

48

There are also video instructions:

Better to paste the git command in a Terminal window. See the video instructions starting at 0:26. That way, it can be kept up to date more easily.

Thank you for that detailed reply. I understood what you meant by installing the modules. But it’s not loading. Even if I install the scripts through the GitHub it’s still not loading the modules.

I see. On Catalina, you may have to allow Glyphs to access the full disk. System Preferences > Security & Privacy > Privacy > Full Disk Access, then add Glyphs with the plus button:

Also make sure that you have the latest cutting edge version: Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

And finally, make sure there is no firewall or antivirus software blocking Glyphs. Best to follow the same advice as laid out in this tutorial: https://glyphsapp.com/tutorials/cannot-download-or-update-glyphs

I installed the scripts through ‘Github Desktop’ I updated to Glyphs 2.6.5. I activated Glyphs with Full Disk Access, I do not have any Firewall or any ‘Helper’ apps activated. But still, the modules aren’t loading.





Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

That worked! Thank you so much for your time.

2 Likes