Segments not appearing when right-clicking to implement

Hi there, beginner here getting to grips with Glyphs Mini. I have created a segment and am trying to use on a shape - but can’t find any way to attribute when I right-click (although the .Corner shapes are working as expected) - it is my understanding once a .Segment is created it should show up as attributable but doesn’t seem to be the case

any suggestions appreciated on this! recognise I am probably missing something very obvious being this novice, but can’t seem to crack it!

You need to select the entire segment (both nodes) in order to add a segment component. You can also click onto the segment (the line between the two nodes) in order to select it.

1 Like

Hi Sebastian,

Thanks for responding! I am trying that too (screenshot attached) and seem to still be having the same issue

For reference this is the .Segment I am trying to attach

You need the prefix _segment, all lowercase.

1 Like

Hi Rainer, I have just tried that but still no luck it seems

also FYI I am on the trial version – does this version allow _segment functionality?

Glyphs Mini doesn’t support segment component.

1 Like

Thanks Georg!