Selection in Font Tab and Transformations Problem

Version 2.3.1 (922)

Transformation doesn’t work, I think Glyphs doesn’t seem to recognise that I have selected all glyphs, I’ve noticed if I apply a transformation successfully to all glyphs, then try it on another master, it only affects one glyph.

Please see videos and file I have emailed:

Video 1
Video 2

Also not sure if related to the above: the metrics value doesn’t revert in the info when I run transformations and hit cancel…

Bump: I’m trying to do a scale (constrained) from baseline transformations and can’t because Glyph doesn’t think I’ve selected glyphs… :cry:

When I transform, it’s still working only on one glyph, and when I cancel it doesn’t undo either…

Transform still doesn’t undo when you click cancel.


I just tried that again and it is working as expected for me. Can you remove all plugins and test it again? Is it still a problem with the latest beta?


Both problems still exist in Version 2.4b (926), even with all plugins removed.
Ill send you video and the file in question.

Thanks for sending you font. The problem was only apparent with this particular font. But now I cold fix it.

I just uploaded an update that fixes this.

1 Like