Serif Corner Components interpolate strangely

[edit: updated the picture to show the problem better]
I’m using corner components for the serifs and on the diagonal stems the serifs interpolate as if they are switching through the corner alignment settings. The issue doesn’t appear with the vertical stems. Also the weights that I have actually drawn turn out fine. I checked shape order and also the direction of the corner components, and so far I can’t see where this issue stems from.
Thanks for looking into it.

Can you check the alignment setting and scale in all masters?

Went through them, and wasn’t able to see any outliers. The alignment settings (is it “Metriken?”) are the same all over the various weights. The weight slider is increasing in steps of 100 per weight. The stem value is derived of the uppercase letters. I can send you the file if that helps

The alignment settings refer to the corner components. Click on a corner component and check the settings in the info panel. There are multiple options of how to align them, make sure they have the same settings in all masters. Same goes for the transformations: make sure they aren’t mirrored in one master and normal in the other.

Or are mirrors horizontally in one and vertical in the other. I recommend to always flip them horizontally.

Bildschirmfoto 2023-04-08 um 10.40.13
So Check the minus sign in the scale field and the arrow settings.

There are, though, quite a few occasions where I have used correct alignment and transformation, but interpolations still get messed up:

I have encountered this so much that I always decompose all corner components before export (which works fine), I’m afraid they are still too unpredictable.

Can you send me that file?

Do you mean me? Sure I can. I’ll try to find some other files where there were similar issues, but I can’t remember auf die Schnelle.

Both of you ;).


As I thought, the alignment is different in the “sans” masters.

Thank you @GeorgSeifert for the quick response.
So for future reference: The problem needed two thinks to get fixed.
First one was an alignment issue in the Sans Serif master that I thought wouldn’t be an issue in the Serif one.
After I changed this the alignment now looked strange the Sans version as now some wonky additional curves showed up.

This was solved by making the curve handle kind of a zero handle—meaning I had to move several points to be layered on top of each other.