Set first node bug, v. 2.3b 879

Glyphs tries to set one of my off-curve handles (which ATM is the lowest coordinated in the drawing) as first node, and does not react when I try to set the correct node. This results in incompatible outlines between masters.

I can’t reproduce this. Could you send me that glyph?

I am not so sure anymore if I am describing the issue correctly. I first encountered the issue with some v-shapes with rounded apexes (but no apex point). It is quite hard to tell what the first node marker actually points to, so I assumed it was one of the off curve points. Copy-pasting back and forth from FLS solved the issue, so none of those shapes are problematic anymore. But, here’s an oslash that shows similar issues: incompatible, despite having the same amount of nodes, counters and anchor points across masters – all ordered in the same direction. (10.8 KB)

Thanks for the file. I fixed it.
You should be able to set the first node to something else and then back to the actual start node.

Inner top counter of the third master was the culprit:

Will this be fixed in future updates?

I fixed that. For now, set some other node to be first and then run Correct Path Direction again.