Set new Variable Font Origin when using Disable Masters

Hello, I have a project with roman and italic in one file. I would like to export to variable fonts: one roman, one italic. I was thinking of adding the Disable Masters custom parameters to each of the two variable font settings in order to create the subsets (as this is supposed to work now). Problem is I cannot set the variable font origin.

I have six masters: Thin, Regular, Black, Thin Italic, Italic, Black Italic.
In Font Info > Font, I have “Regular” set as the variable font origin.
For the roman variable font setting I add the following custom parameter: Disable Masters (Thin Italic, Italic, Black Italic).
For the italic I of course do the opposite and add Thin, Regular, Black to the Disable Masters parameter.
Now I cannot control the variable font origin anymore, though.

Is there some way of setting these exports up? Otherwise, I would simply split the file into two, this still seems the easier way. Thanks for any pointers.

You should be able to set a “Variable Font Origin” cp in a variable instance.

I agree, but that cp doesn’t exist.

Edit: in 3.2 it does. Thanks!

Hello again. I would love to use the functionality of Disable Masters to generate subset variable fonts.

In 3.2, I am getting an error (which doesn’t appear in 3.1): “Instance outside of interpolation space”. Of course it is, that’s the whole point, I would like Glyphs to just ignore this instance upon export.

Second thing: glyphs with intermediate layers behave very weirdly. Scenario: I have a family with width and weight axes. I want to export just the “Normal” width family, so I disable the other width masters (side note: the width axis is disabled when exporting from 3.2, this was not the case in 3.1, yay! Thanks!). I have a glyph with an intermediate layer located on the width axis outside the interpolation space of the “Normal” width masters. On export, the glyph now grows and shrinks:


Any way to remedy this? Apart from this issue, I am very happy with the subsetting process! Thanks a lot for making this work.

It ignores instances and brace layers now.

Do you mean, currently, it ignores brace layers? Is a fix for this planned? Would be immensely appreciated :slightly_smiling_face:

It just keeps exporting them right now. That, of course messes things up.