Setting component to "mask" has no effect on export

Hello, I noticed that my blackCircled numbers were simply black circles, without the numbers.

In Glyphs, I have a circle component with a number component on top of it, with the number component set to “Mask”. In the Glyphs preview, everything looks good, but the exported fonts show up without the mask applied. Decomposing the components in Glyphs also results in black circles.

However, setting the component to “Reverse” works. Is this intentional?


What is the point of the Mask attribute, then? If the preview shows it correctly masking, why is this not reflected in the exports? At the very least, this is misleading.

It is not intentional but the current implementation made it too difficult. We’re working on it.