Setting Font Sample Text for Glyphs in Private Use Area (PUA)


I am making a custom font for a set of 639 icons which occupy the Private Use Area (unicode range E000 - E283). Everything works great, except I cannot seem to be able to set any sample or preview text for the font that would otherwise be displayed when using quicklook or the thumbnail preview of the file.

I have tried setting it via ‘Glyphs > Preferences > Sample Strings’ but I’m not sure whether the app is expecting me to type “uniE003”, “\E003”, “U+E003” or to simply copy and paste the result encoded result into the space (none of which seem to yield any results). Am I missing something?

So my question is, how do I set sample text for the glyphs I have made which occupy the Private Use Area?

1 Like

You have to use /uniE003

Thanks for the quick reply. Doesn’t appear to work though. I ran a test by editing the sample strings and using /uniE003 and I’m still not seeing any sample text appear in the font file’s preview after export. Any other ideas?

You can’t change the QuickLook appearance in the system. It uses a build in text.

The sample strings are there to add them with the Edit Menu > Sample Text …

Hmm, ok. That makes sense.

I was reading though on Github’s blog an article regarding their creation of their font based icon set “octicons” ( and they use Glyphs App to create their final font set. When they converted the OTF file to web fonts use Font Squirrel’s @font-face generator the webfont outputs all show unicode previews in Quicklook. So I am wondering how they were able to achieve the same results?

Perhaps they simply mapped a few of the glyphs to latin characters for this purpose?

Thank you for your reply though.

probably they did that.