Setting up font with masters narrow to extended in light and bold weights

Hi guys,

I’m struggling like hell. I’m trying to set up a Glyphs file with the following structure:
Master: Font Light
Instance: Font Regular
Master: Font Bold

Master: Font Light Extended
Instance: Font Regular Extended
Master: Font Bold Extended

Can anyone show me how to set this up in Glyphs? Please, show me the settings I have to make before I loose my mind.
It might well be very simple, but my brain just won’t show me the solution.

Thanks in advance.

Did you read the multiple master tutorials?

Yes, all of them. But like I said, for me personally, it doesn’t work. The idea is clear, but I can’t seem to get the settings correct. Always things change in the instances I have already set up.

It’s me, I know. Therefor I called in the cavalry. :wink:

What version of Glyphs do you have?

I’m on 2.4.4

Can you post screenshots of the master and instance settings?

Sure. I deleted the new settings before, because it just wouldn’t work. How difficult can this be? I feel kinda stupid. :wink:

Here we go:


The instances have to have the same Weight values as the masters.

I had this all along, before I switched to this. I’m now back to the old setup, which works fine.

But this still doesn’t help me how to name the new masters and instances. :vulcan:

The master names do not really matter. They are just for you. And the insurance names will go into the font. So use whatever you like to have in the font menu.

okay, then more concrete. I hope this setup is done correctly!


The million dollar question is: how to set up the instances that I get 4 correct OTF fonts as output?

Forgive my stupidity but this is just crazy difficult for my brain. Just like coding, I can’t see through this.

PS: I just spotted the weight problem on the Light Extended. It’s now 100.
Not that it makes a difference, but I see the response coming. :sunglasses:

Why Horizontal Stems should be kept the same through all masters?

1 Like