Shift Increment not working in Spacing & Kerning Shortcuts

Also, after my new clean install Shift is no longer working when spacing or kerning (10 unit points).

Any ideas? I checked in my mac shortcuts and I can’t see any conflict with any other shortcut.


There is a system wide shortcut for Spaces that uses Cmd+(Shift)+left/right.

Thanks Georg. I checked all shortcuts and there seems to be no such one for spaces. It is a real bummer since before re-installing OS it was working fine.

My ideas:

  1. Check if a different menu item has the shortcut: anything that happens in the menu when you press the shortcut? If something highlights briefly, you know where to look.
  2. Do you have a third-party tool, that has a default shortcut that interferes? E.g. a window arranger like Divvy? Or a screenshot tool?
  3. Verify your keyboard layout in System Preferences.
  4. Perhaps you have garbled settings for increments. Run this in Macro window, or use the mekkablue script App > Set Hidden App Preferences to delete these:
del Glyphs.defaults["GSKerningIncrementHigh"]
del Glyphs.defaults["GSSpacingIncrementHigh"]

Hey Eric! You are awesome. The problem was number 4. I run the del’s in Macro and now it works fine.

The only thing I have tampered with was installing and uninstalling Change Keyboard Increment plugin, so I think that when it uninstalls it leaves something messed up. You can try and see if you can recreate the issue.

1 Like