Show Variable Font Preview 3 doesn't show slider reliably

I’m seeing strange behavior with Variable Font Preview. At least half the time I try to use View > Show Variable Font Preview 3, the sample window pops up, but the slider window is missing. I usually repeat that process and it shows up. Sometimes I repeat that process numerous times and finally give up and do something else because won’t show the slider (I tend to work with just one axis). Also, sometimes instead of my sample text, the preview popup just shows a capital “A”. This issue doesn’t seem to be specific to any Glyphs file.

I haven’t seen the issue reported here, so I’m wondering if it’s something to do with my own machine. This is my setup:

Big Sur Version 11.5.1 (20G80)
Mac mini (M1, 2020)
Glyphs 3.0.4 (3106)

This Mac Mini, rather than being speedy, has a long delay when I try to use a Spotlight Search. I have wondered if that same delay is somehow affecting the Variable Font Preview. Has anyone else had issues with Variable Font Preview?


Hi. Does it also happen when you have just one file open?
Also does it happen when you have all other Reporter plugins turned off?
Does it happen with any font file?

Mutilple open fonts are a known problem which I am trying to solve, for some reason those give me a big headache. There is something going on with retrieving the current font, where the font from the background always cuts itself into the front, causing some flickering UI. Current workaround for this particular issue is to just have one font open.

But my M1 Mac doesn’t cause these troubles you report. I cannot think of any reason why the spotlight delay should be related in any way.

Would you mind sending me this file or a dummy file that also causes the issues for you?

1 Like

I often have multiple files open. I will do some experiments with just one file open to see if that fixes the issue.

@russmcmullin Let me know, and please add me here, so that I can get a notification when you write to me :slight_smile:

@Mark I have tried with 3 different font files and I get the same result with each. Which plugins are “Reporter” plugins?

I tested just now and here is what happened:
I tested a file with 3 masters on the weight axis. All of glyphs showed that the masters were compatible. I selected six glyphs on a row, and double-clicked to view them together. Used Ctrl-Option-Command-V to bring up Variable Font Preview 3. I see the slider, but the preview popup is blank with no glyphs visible. As soon as I click the slider, the glyphs instantly appear in the preview popup. The slider then works as expected. I use the red dot to close the popup. I select another 6 glyphs, double-click them, and use the key command to bring up Variable Font Preview 3. This time the preview popup is populated, but there is no slider. I use the key command twice to make the preview popup disappear and reappear. When the preview popup appears, the slider is there. I close the popup (it doesn’t matter whether I do or don’t, the issues are the same. I just do it out of habit.) I select 6 more glyphs, double-click them and use the key command to show Variable Font Preview. I see the preview popup and no slider. Use key command twice and now I have preview and slider. This is typical behavior. Nearly every time I have to hit the key command 3 times to get the preview popup and slider together. Sometimes it works on the first try, but rarely. If it would always work like this, I would consider it annoying, but not a major interruption of workflow. Unfortunately, there are other, less common, issues.

I open another file, leaving the first file open. This file has 2 masters on the weight axis. I select 6 glyphs and double-click to preview them together. I use the key command to bring up Variable Font Preview. Nothing happens. I try this multiple times with various sets of glyphs—no preview popup and no slider appear.

I close the first file and and repeat the procedure with the 6 selected glyphs. Now I can see the preview popup. The slider is missing. I use the key command twice and the slider appears with the preview popup. So, it seems not to matter which file I’m using. I get the same basic behavior.

Some behaviors are rarer, but not uncommon. There are times when I can’t get the slider to appear even after multiple tries with the keys. The behavior is the same whether I use keys or dropdown menu. I use the keys because they are faster.

Sometimes even the preview popup will be unpredictable—populated with a string of glyphs that I have already closed the tab for—seemingly cached. That string of glyphs stays in the popup window and won’t go away no matter how many times I toggle the key command. In situations like that I just move to a different task and come back to Variable Font Preview later. Eventually the cache clears (or whatever it is), and I am able to resume using Variable Font Preview again, but with the same problems as previously described.

Hopefully this information is useful. Let me know if I can provide anything else.

Thanks for the details, @russmcmullin

About the multiple files: as I said, that’s knwon and I am working on fixing it, so let’s for now focus on the “popup” for a moment.

First, what do you mean with “popup”? Is it the standalone preview window?

Why are you always closing it, anyway? You can just leave it open, by just leaving the plugin active. You don’t have to always close a tab and select another bunch of glyphs and open another tab with them. I mean, generally. You can also change the content of a tab right inside a tab. But still, if you want to select glyphs and open a tab by double clicking, you don’t have to close the “popup” (standalone preview window) each time before doing so and then reactivate the plugin. Just leave it active.

Are you aware, that you don’t have to use the “popup”? You can also use the preview attached to the current editTab. Maybe start with this, which might reduce some confusion about the preview/window-active-state.

Of course I will try to fix the missing slider issue, but I also think you’re burdening yourself with too many redundant clicks and toggles to begin with, which complicate the entire use of GlyphsApp and the plugin. Would you mind trying to leave the plugin active for a little time (meaning, don’t close the popup with the red dot, and also don’t deactivate the plugin from the view menu), even when switching/closing/opening tabs, and see how/if that changes matters?

“Reporter” Plugins are all plugins that you can see unter the “view” menu, there usually preceeded by a “Show …” – Or any plugin that is toggle-able by the “Reporter Toggler” plugin.

@Mark Thanks for your feedback. I have been using the plugin the best I knew how. As far as I am aware, there is no documentation to explain its use. I went to your website just now and found video snippets for version 2, which helped me figure out how to get rid of that popup. The video snippets don’t have much context, so I’m not always sure how to make the interface do what I see in the animation. As I have experimented, I have discovered how more things work.

Keeping the popup active all the time, or killing it and reactivating it makes no difference—the unpredictable slider behavior is the same. Now that I know I can get rid of the popup, I will never use it again. It must have been active my default. I like how I now have a longer space to preview a string.

Even without the popup, I still see problems with the slider not being visible. For example, I check to see that the plugin is active, I select a row of glyphs and double-click. The slider is not visible above my string of glyphs. I verify again that the plugin is active. There is a check by it, but I see no slider. I use the key command to toggle the plugin, and the slider appears.

Of course, if I stay in that same preview window, I can type new things and the slider stays there. But, if I try opening a new string of glyphs in a new tab, the slider will probably not be there. If the slider is visible, I can touch an individual glyph and it shows up in color. If the slider is not visible, clicking an individual glyph doesn’t show the glyph in color—it stays black.

Oddly, if I move back to a tab that had a visible slider, that slider will be gone. I can still see the active glyph in color, but there is no slider to make it do anything. If I use the keys to toggle the plugin off and on, the slider comes back.

My current workflow is for verification. I am checking for glyphs that appear to be compatible—not flagged with red—but when tested they morph incorrectly. I have been going through and fixing glyphs as I find them. That is my reason for selecting a row of glyphs and testing them as a string.

I will try deactivating the other Reporter plugins and let you know if it changes anything.