Smart Components

From an update 2.0.1 smart components are interpolated through all masters. But I have a file with 3 masters and it looks like the middle master is being omitted.

And it is not working as described in the tutorial. How to deal with this new functionality?


Can you please try again and send me the file to support or res (at) this domain? I didn’t receive anything the last time.

Three master setup are not properly supported. I would like to see your file and see if I can fix this.

Ok I sent it again to both of You. Thank You.

I use this thread for my question. How can I set piece settings via Python? There are pieceSettings() and setPieceSettings_() and I can see values in the former, but haven’t been able to set it.

I’ve got similar problem as dadastudio’s but with 2 masters: light and regular.
When I’m starting to interpolate within “regular” master, it’s starting to make unforeseen changes ( for example smart component is using as a master “light” version instead regulat).

Can you send me your file?

Smart components Settings interpolate through all masters, so you do not need to redraw all your smart glyphs on all your masters, but just draw master ‘bold’ as an additional smart layer & add the property ‘weight’, and assign it to all smart layers. This is new in 2.0.1 and multiple master is not covered by the tutorial.

1 Like

ok. but as long as it doesn’t support more then 2 masters I can’t upgrade. Do You plan to add the support soon?

I changed it already to not use all masters as long as you don’t add a ‘Weight’ parameter. It only responded to that particular name, so if you need a weight axis but don’t like to include all masters, just pick a different name.