Smart corners components in Interpolation

Hi there designers!

I’m trying to interpolate between two masters (one light, one heavy). I’ve tried to test one of my characters (lower case ‘m’) and while the weight distribution works great, I’ve noticed it doesn’t interpolate the corners. I have smart component corners for the light and the heavy masters, but they just don’t seem to interpolate when previewed for some reason. They only show up at their extreme weights as shown.

Can anyone help as to why this is this case?


Smart corner component?
Do they preview in the lower preview area?

Hey @mekkablue

No they do not. They appear as straight lines without any corners. I’ve tried to follow the tutorial

The only way they interpolate is if I decompose the corner components on the masters. But that means I’m unable to preview how they interpolate. Surely I’m doing something wrong and they can be previewed without decomposing?

Are the corner glyphs compatible?

Thank you both for the quick reply, champions! I’ve had a look and noticed I had an anchor missing in the ‘light’ master for the corner component, so now the glyphs are compatible.

But now something else has happened. The tip of my stem doesn’t seem to interpolate like the rest of the corners when previewing interpolation. Have I again set up something strange?


Got it! I noticed that in one the corner hints the width was at -100% for the Light master, while the height was -100% for the Heavy master. I didn’t realize I had changed the percentage values when previewing View > Show Hints. It all ‘looked’ compatible but it was just this setting that changed everything.

Thanks again for your helps!