Smart filter with regex

I can’t get Glyphs to use this regex in a smart filter for glyph-names:

It works fine in a text editor. What am I doing wrong in Glyphs?

The Smart Filter works for me.

You can simplify the regex to: .+\.ss[0-2][0-9] (note the \ before the .)

So bizarre! Now it works. I was pretty sure that I tried setting it to ‘matches’, but perhaps|obviously not.