Snappers not showing in Glyphs 3

So far it works, thanks!

Btw how to show the redline that pop out when I move the nodes in the same x/y coordinate as the other nodes like in Glyphs 2?

What redline do you mean? Can you post a screenshot?

When I move down the left node to match the right one

To this

What output do you get when you run this in the macro panel:


When I just open Glyphs 3:

Traceback (most recent call last):
  File "<macro panel>", line 1
AttributeError: 'NoneType' object has no attribute 'snapToObjects'

When I open the file


Can you try in a new file and without plugins (Hold down Option+Shift when you start the app).

It says True

I does the snapping work without plugins?

Nope, doesn’t work.

Should I remove all plugins first before I tried to hold down Option+Shift?

No need to remove the plugins, Option+Shift should ignore them already. But maybe do it anyway, to be sure (rename the Plugin folder).

Okay, just realised my Option+Shift doesn’t work before so I just rename the folder to remove the plugins. The snappers still doesn’t work like the Glyphs 2 one, it only snap into it’s previous coordinates when using mouse, doesn’t work if I use keyboard and doesn’t snap into other nodes.

It works for me when I use the keyboard. Can you try in a new font?

Yeah, I tried new font, still doesn’t work.