Snapping drives me nuts sometimes


#1

A quick search revealed that I’m not the only having issues with overeager snapping. Holding Ctrl doesn’t change anything for me :confused: Maybe you are familiar with Affinity Designer, it has a Snapping Manager. Something similar would be very cool for Glyphs – fine-grained control if you want the handles not to snap to nodes, and components only to components. Maybe it’s a job for a plugin?


#2

1000 × yes, please! I often wish there was a way to just disable snapping and suggested node positions completely. For some fonts it just doesn’t make sense.


#3

Include me in there too.


#4

I quickly put together this plug-in hack for Glyphs 2.5:

Activate it via Edit > Kill Snapping. It reduces snapping for the current tool, does not completely turn it off, sorry.


#5

+1 for ctrl to disable snapping. Also to lose the red snapping lines that sometimes appear.


#6

Could you send me some sample data where the snapping is a problem? And a small screencast what you are trying to do. That could help me improve the default behaviour.


#7

I‘m away from my work computer for a while, but I‘ll try to remember to make a screencast when I get the situation that illustrates the problem well. Basically it‘s every time when I try to drag a handle in a somewhat crowded environment (like the bowl of an /a) that I find myself thinking No … WTF … just … let me … drag the goddamn handle. It‘s also rare (for me at least) that I would want the BCP to align with nodes the BCP don‘t belong to.

The other side of the medal is when I‘d like some snapping to quickly align the components for example, and it just won‘t do it. Snaps to everything else but the thing I want it to snap to. Glyphs can‘t read my mind, but if snaps to everything, at least the other component should be among the candidates :smile:

Btw, I believe the snapping used to be far less aggressive in earlier versions, but maybe it‘s subjective because I work on more complex projects now.

@mekkablue Many thanks for the script, like I said, I won‘t be able to test it for a while, but maybe others can chime in.


#8

This is one of the “features” I never experience myself because I never move a node with the mouse (only at the very beginning to roughly move the points in place). I use the mouse to select nodes, but then I move them with the keyboard. I strongly encourage everybody to do the same but I don’t force this – I just need more feedback on this one.

How do you need snapping with components? What are you trying to do. Did you try to use anchors?


#9

The thing that bothers me with snapping is when I’m Ctrl+Opt dragging some node and it snaps to another one. Most of the time I don’t want snapping when Ctrl+Opt dragging. The red lines are useful and I don’t mind them at all. Also, in this case I can’t hold Ctrl to ignore snapping as it is part of the other key combo.


#10

Please check out anchors and automatic alignment. read the Diacritics tutorial, for instance.


#11

I suppose some improvements can be done not only with the issue of snapping, specifically when being assisted by rough grids; minor distortions on paths may occur that often are not noticeable.


#12

Here’s an example of having a handle to snap to everything, while I don’t need it snapping to anything – just dragging it around to see the smoothness of the curve. I still couldn’t check out mekkablue’s script though.


#13

Hold down the Ctrl key while dragging.


#14

The other day I had trouble using the mouse and editing an s-shape like glyph. The snapping was really annoying there. And I am one of the ppl who often use a mouse for node editing. Not a fan of keyboard only bezier editing at all. :slight_smile:


#15

The problem with using Ctrl to disable snapping is that Ctrl is part of Ctrl-Opt dragging for interpolated nudge dragging. In that case there is no option to turn off snapping (other than Rainer’s plug-in, thanks!). There really should just be a built-in option to turn it off along with the red guidelines.


#16

As I said above, Ctrl does nothing for me, it’s still snapping to everything :confused:


#17

Are you sure you are holding down Ctrl?


#18

This is me laying down the basic points over a drawn background. Really, none of these points should snap to anything in this case.

glyphs-snapping

For comparison, this is the final form that I’m after, still no snapping necessary …