[Solved] [bug] [mini] Line components can't be selected

if I create a line (as in, a line whose path is open),
and convert it to a component,
when I place this component in a glyph and try to select it with the mouse
it can’t be selected when you use the mouse “click, hold, and start dragging with Option key”

GIF


in this screen capture, I placed two compoents:
1st.- A rectangle (a closed path) component, this works fine,
and also place
2nd.- An open path component, this is the one that isn’t selected when I drag the mouse.

beta 104, thx

EDIT: Lasso tool as well doesn’t select them

I see. But also are those components not useful as those paths will not be exported.

Yes thanks, my idea is to decompose them and then use the Offset filter to give them thickness.
also, found a new bug, the rotation of these components is not saved.

I can’t reproduce the rotation issue. Can you explain what you did?

sure, I have a line component, a vertical line, which I placed in glyphs “a” and “s”:


Then, I do these steps
1.- I rotated the one in “s” to 90

2.- and rotate the one in “a” to 90 as well.
3.- Then I and Saved and closed the file

4.- Then I reopen the file, and notice that:
5.- the one in “s” goes back to its initial rotation, and
6.- the one in “a” rotates even further, to 180:

file attached:
test.glyphs (10.8 KB)

GIF of what I described above happening with the “s” glyph:


GIF looks like a loop, but that’s because the component rotation was not saved when I reopen the file.
the start of the screen capture is when I select the component and rotate it.
When I do File>Open Recent that’s the middle of the screen capture.
When I scroll the glyph into view that’s the final part of the animation, showing its rotation didn’t get saved.

beta 104

another rotation issue, this time with a closed component:
I set rotation to -90,
50%20PM

but when I reopen it, doesn’t save rotation:
49%20PM

Attached file
rotation 2.glyphs (12.0 KB)

beta 105, also happens on Stable in this file.

That happens if you rotate and not uniformly scale the components. I can’t fix that at the moment.

Edit: I had another look at it and it seems that I fixed it.

1 Like

Just upload a new version that should fix this.

confirming it’s working :+1:
huge thanks!!