[SOLVED] Glyphs 2 won't launch

I get this when I launch G2


Any suggestion please?

Looks like the checksum of the app bundle did not check out.

  • Are you using a system maintenance tool like MacCleaner? If so, don’t.
  • Which macOS version?

You will need to redownload the app binary.

Thanks for your quick reply!
I don’t use any system maintenance tool.
I’m using the macOS Mojave 10.14.6
And I re downloaded the app binaries and still get the same error unfortunately.

Can you send what you get when you click “Report…”? There should be a text box. Please post the first few text blocks.

Here is the full text:

Process:               Glyphs [75108]
Path:                  /Applications/Glyphs.app/Contents/MacOS/Glyphs
Identifier:            com.GeorgSeifert.Glyphs2
Version:               2.6.5 (1342)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Glyphs [75108]
User ID:               501

Date/Time:             2020-09-04 22:32:46.637 +0200
OS Version:            Mac OS X 10.14.6 (18G6020)
Report Version:        12
Anonymous UUID:        25C87170-142D-B62D-AE85-294A2F231AA0

Time Awake Since Boot: 200000 seconds

System Integrity Protection: disabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.7/Python
  Referenced from: /Applications/Glyphs.app/Contents/MacOS/Glyphs
  Reason: image not found

Binary Images:
       0x109a2a000 -        0x109b71fff +com.GeorgSeifert.Glyphs2 (2.6.5 - 1342) <012FCADE-55B3-30FD-A31C-C0BD0905C945> /Applications/Glyphs.app/Contents/MacOS/Glyphs
       0x109bdd000 -        0x109c23fff +org.sparkle-project.Sparkle (1.21.3 - 1.21.3) <C4292B72-AEA2-306B-8784-AD3D5FBE5404> /Applications/Glyphs.app/Contents/Frameworks/Sparkle.framework/Versions/A/Sparkle
       0x109c5b000 -        0x109c6aff3 +com.flyingmeat.JSTalk (1.0) <E1A3BAD3-C62A-3F72-9350-BAF9E9BE8DDC> /Applications/Glyphs.app/Contents/Frameworks/JSTalk.framework/Versions/A/JSTalk
       0x109c8b000 -        0x109cc0ff7 +com.schriftgestaltung.GlyphsKit (2.3.1) <6F1FE038-9686-37FE-BAEF-5FEB4F41E09F> /Applications/Glyphs.app/Contents/Frameworks/GlyphsKit.framework/Versions/A/GlyphsKit
       0x109cee000 -        0x109d9dff3 +com.schriftgestaltung.GSFontTools (3.0 - 1) <7B0424A8-DE32-3076-A7C7-3EF6A538A3DD> /Applications/Glyphs.app/Contents/Frameworks/GSFontTools.framework/Versions/A/GSFontTools
       0x109e48000 -        0x10a0e1fff +com.schriftgestaltung.GlyphsCore (2.3.1 - 1) <862E1AC3-2323-3C13-8522-85571D729543> /Applications/Glyphs.app/Contents/Frameworks/GlyphsCore.framework/Versions/A/GlyphsCore
       0x112f19000 -        0x112f8370f  dyld (655.1.1) <91A01B2E-622F-3FBC-8D67-AC6D5D1C0023> /usr/lib/dyld
    0x7fff4ba35000 -     0x7fff4ba35fff  com.apple.Carbon (158 - 158) <BE5FB24D-510F-3AE6-A455-79BFDEB99AEC> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

Nevermind, solved by reinstalling Python 2.7 :+1:t2: