Some metrics keys are out of sync after converting to Glyphs 3

Hi! After upgrading to Glyphs 3, I noticed that some of the glyphs are now reported as having “metrics keys” out of sync.

Clicking on a glyph shows red kern label.

I’m happy with how glyphs look, but since it’s a warning, it makes me uncomfortable leaving it as is. Clicking on “Retry” arrow removes the warning by changing glyph width.

This is now what I want to happen. But most of all, I want to understand what this warning is about. This is what I don’t understand:

  1. What are the metrics?
  2. What are the keys?
  3. Which keys are not synced (assuming there’re more than one)?
  4. What are they synced between? What’s the other side?
  5. Is there a way to get rid of the warning, but leave the glyph width the same (it’s a monospaced font).

Glyphs file (before 2→3 conversion) could be downloaded from


In Glyphs, metrics (such as left/right sidebearing and width) can either be set to number values or to the metrics of other glyphs (called “metrics keys”). If a metric is not set to a number, but instead to a glyph name, as is the case in you example, the metric of the named glyph is used.

In your case, the Epsilonpsili uses the left sidebearing of the Epsilontonos and the right sidebearing of the E glyph.

The metrics in red with the retry arrow are out of sync. These out of sync metric are in glyphs that have an alert triangle in the top right in Font View. You can use a smart filter to show only glyphs with out of sync metrics in Font View.

The metric of a glyph is synced with the metric of another glyph. For example, the width of the plus + glyph could be synced to the width of the minus − glyph. Then, whenever the width of the minus changes, the plus glyph gets marked as out of sync. This is always only in one direction.

Yes. There are two options:

  1. Remove both metrics keys from the Epsilonpsili. You can do this by clearing the fields for the left and right sidebearing. This keeps the glyph as is.


  1. Only remove the left metric key. You might still want the right side to have the same amount of space as the E glyph. In that case, keep the metric key on the right and only remove the left metric key referencing the Epsilontonos. This option also keeps the glyph as is, but if the E glyph would change its right sidebearing in the future, then Epsilonpsili would again be out of sync to let you know of that difference.

Note that opening a Glyphs 2 file when opened in Glyphs 3 is still in “Version 2” format. Not all features of Glyphs 3 work with the version 2 format. Change the format in FileFont Info…OtherFile format version if you want to use all of Glyphs 3 features.

1 Like

Thanks, that makes it very clear! I wonder where Epsilontonos comes from? Used to be (auto) on both sides in v2

Did you get a dialog about changed metrics when you opened the file for the first time? For all glyphs with checked boxes, the automatic alignment was disabled (Glyphs 3 changed the algorithm a bit. This dialog warns you about that and allows you to keep the position of the component).

1 Like

Ah, I see. The Epsilonpsili was automatically aligned in Glyphs 2, but it is no longer in Glyphs 3. This is because in Glyphs 3, only top and bottom anchors are propagated through components.

So the psili component can no longer attach to the topleft anchor. The topleft anchor is defined in the E glyph, but Epsilonpsili does not use the E glyph, but the Epsilon which in turn uses the E glyph.

To fix that, add the topleft anchor also to the Epsilon glyph. Now the Epsilonpsili can be auto-aligned again. Use the anchor menu to choose which anchor psili should use. Here is a movie demonstrating this process:

1 Like

Or use the E component directly.

1 Like

Thanks, that’s very helpful to know as well! And yes I got the dialog, kept everything in place, but got those warnings. I think I know what to do now, thanks again for helping!