Some shortcuts not working

Since installing Mojave, shortcuts like cmd+shift+R and cmd+S stopped working.
I have the latest Glyphs version installed.
What can I do to fix this?

Have you set any shortcuts in System Preferences? And did you select “Use Version” in Glyphs Preferences (I’m strongly advising agains it)?

I haven’t set any shortcuts in System Preferences and “Use Version” is not selected in Glyphs Preferences.

Can you make a screenshot of the File menu?


And what do you mean by “stopped working”? Do you get a bing?

You might have this problem: Since 2.6 I have to save files twice

Yes, I have the same problem as described in the link you’ve provided with cmd+s (no bing in this case).
But, with cmd+shift+R I get a bing every time I use it and if I do it twice it still doesn’t work.
I can only correct the path direction if I do it manually on the “Paths” menu.

Can you post a screenshot of the path menu?


And is the Paths Menu highlighted when you press Cmd+Shift+R?

No, it isn’t.

Then there is a global system shortcut stealing the command. Go through all the settings in System Preferences and see if anything has the same shortcut.

I went to System Preferences - Keyboard - Shortcuts and verified everything carefully and couldn’t find that shortcut being used.

Any other software you installed on your system? Something showing up in the menubar? Think of apps running in the background, like Dropbox, Evernote, 1Password, etc.

Found the culprit. I was using an app (be focused) that used the same shortcut. It’s solved now.
Thank you both for the help!

1 Like