Something went wrong with the remove Overlap filter

When the number of points for the glyph drawing a certain number, refrain application for the export of the font and this message appears

Something went wrong with the remove Overlap filter

It made me feel like I write a message via twitter certain number of characters!

There are some problems with the remove overlap filter that it just does not work and the app can’t tell why. The most common things are to many nodes (nor sure what number but something around 1000) or a to big drawing (more than 8000 units wide).

Sir Georg
Points drawing did not exceed 150 points

Can you send the font to support [at] this domain?

Sir mekkablue I can not Send My Font for reasons I mentioned

I work in the field of the design of the Fonts, and sold to companies and small businesses, and I’ve made Glyphs App suddenly in one location, and it has been tried on a lot abbreviated in the programming of the fonts

That’s why I bought both versions of it, and after a depth and directed a lot of problems which I have spent time in support of the developer more than I have spent working on the program

Even an activation code which I received via e-expired, this activation like to set up a temporary in a hotel!

And now I stand unable to find a solution to this problem

Can you track it down to the glyph that causes the problem?

If you know which glyph it is, check:

  • if you have duplicate paths
  • if you can simplify the path (reduce number of points)
  • if you can manually remove overlap (select 2 paths, then choose Filter > Remove Overlap)

Two things:

  1. Layer > Decompose (cmd shift D) immediately decomposes all components in the glyph, in one step.
  2. I believe it has not so much to do with the number of nodes, but rather the high x coordinates (>8192) in that particular glyph. Perhaps try moving everything 2000 units to the left, remove overlap, then back again.

I tried what you told me it did not succeed
The problem is not in layers
Problem is the inability to integrate points during export When they exceed a certain number of points drawing
And also can not merge points through the filter!

I am not sure about that because I have had glyphs with far more nodes. Are you able to send us the decomposed glyph at least?

Perhaps another idea.

  1. File > Font Info > Other Settings > Grid Step = 0
  2. Select everything
  3. In the Palette, scale down 50% to the bottom left.
  4. Filter > Remove Overlap
  5. In the Palette, scale back up 50% from the bottom left.

Then, you can set the grid step back to its original value.

I can reproduce the problem. If there is one node with an x coordinate equal to or above 8192.0 (or, equal to or below -8192.0), the remove overlap filter fails. There are workarounds: Moving the whole path far enough to the left works, and scaling down and back up again works as well.

Seems like there are only 14 bits reserved for the coordinates (2^13=8192, 1 bit for plus/minus) in the Remove Overlap code.

When will the addressed problem be fixed? I have the same problem with wide ligatures.


Glyphs 1.x uses the AFDKO algorithm for removing overlaps. You will have to take the workarounds if you decide to have such super-wide glyphs. You can automate it with custom parameters in the instances: Scale to UPM, Remove Overlap, Scale to UPM.

Sir mekkablue
All solutions put forward did not work … I have done more than that to find a solution, but to no avail

Did you make sure there was no node beyond x=8191 when you tried to remove overlaps?

I am afraid I cannot help any further if you do not send me the glyph in question.

Thanks mekkablue
The technique worked

see result

Reviving this thread. I’m getting this error message.Is there any way to know the offending character? I have several icons in my font, none of them seem to be horribly complex, but some might be triggering the limit. Is there a way to figure out which one short of turning off export for them one by one?

Never mind, found a point that seems to have gone for a walk far far away :wink: