Space.vert not recognized in Illustrator


I am just hoping to verify whether this is a Glyphs issue or Adobe issue:

I made a space.vert glyph in my font hoping that it would be used instead of the regular space when I am typesetting vertically. However, it seems like all of the .vert glyphs are acting correctly in Illustrator except for space.vert. However, in Glyphs app, when I switch to vertical view, space does turn into space.vert. I can see that the space.vert glyph is in the glyphs table in Illustrator. And if I highlight the space, it does show that I can switch it to space.vert. However, if I click on the space.vert, it doesn’t allow me to switch to it.

I’ve tried to setup a substitution to turn spaces into other glyphs (with no vector but only set the widths), but it doesn’t seems to work for space glyph at all.

I can’t seem to find any mention of a similar problem here or on Illustrator-related forums. Any insight, workaround or suggestion? Much appreciated.

Is the space glyph included in the “vert” or “vrt2” features?

Maybe you can add vertical spacing to the regular space glyph so you can avoid the alternate space altogether?

Hi, Thank you for responding. Here’s some feedback about these potential solutions:

  1. Yes, the space vert and vrt2 are setup just like how the other vertical glyphs are. And again, all of the vert alternates are working except for space;

  2. I found that it would not work even if I setup the vertical spacing for space, because if I set the text to vertical orientation, it rotates the space by 90° so it’s still using the space’s width as the space. So for example, if the width of the space is 800, then in vertical orientation, it separates the glyph before and after by 800 units, ignoring any vertical spacing settings.

Any other insight about why this is happening would be much appreciated. Thank you.

Can you try in another software? It might be an Adobe bug.