Still having trouble adding my license to Glyphs

I’ve tried multiple times. I’ve tried on the desktop, in my dock, in the applications folder…none of it works.


Seems like you accidentally dragged it into the folder instead of onto the Glyphs app icon. Try again, please.

Try it this way:

  1. Place your .glyphs2license file on the Desktop.
  2. Open Applications in Finder (Cmd-Shift-A)
  3. Click and drag the .glyphs2license file onto the icon in the Applications window

Here is a quick screencast:

That’s what I’ve been trying to do, but instead of going into the app, it goes into the applications folder as an icon on top of the app icon. I’d upload a screengrab, but it’s not letting me as I’m a new user.

Perhaps there is something wrong withe file? Can you send your license file to (support) (at) (this website without www).

It was the file—I asked Jean to upload again, and the second worked.

Thank you for your help and your patience!

This sometimes happens if the file is transferred with a Window email client.

It may have been the minigroup it was posted on. I wasn’t the only one having that issue, turns out. Thank you for your help!

Same problem for me. Just sent email. Hope it can be resolved soon. Can’t wait :slight_smile: