Strange behaviour with non-exporting glyph affecting exporting glyph

I’m experiencing strange behaviour with v-font exporting. I’ve boiled down the problematic glyphs but I can’t figure out what the issue is.

There are two letters Ո (Vo-arm) and Ր (Reh-arm) both of which are made from the Smart Component _part.cap.arch.up. There is also a non-exporting glyph named _Vo-arm.test which is made from the Vo-arm component.

When exporting as a v-font, Reh-arm exports normally while Vo-arm is empty. If _Vo-arm.test is deleted from the font then Vo-arm will export normally.

Does _Vo-arm.test have custom glyph info that contradicts Vo-arm?

_Vo-arm.test just has Vo-arm inserted as a component.
In the glyph info it only has script as armenian which I assume Glyphs guesses because Vo-arm is inserted? The rest of the info is blank.

If I fill in category and subcategory with Letter and Uppercase to match Vo-arm, the result is still the same.

Could you send me the file?

Sent the file via DM. Any luck reproducing the issue?
I just tried with the 1320 update and results are the same.