Style linking .ttf issue in indesign

Hi everyone!
I’m having an issue with ttf fonts on InDesign. When I use shortcuts to swtich from Regular to Bold it works as expected but when I hit again the shortcut it switches to light instead of Regular. Also italic is having a strange behaviour. Everything works fine in TextEdit and Indesgin but using the OTF files of the same font.

Thanks, best.

What are your style linking settings? Everything I know about it is in the Naming tutorial.

The strange thing is only happens on InDesign with ttf files.

Here is my style linking settings:
Light = Nothing
Regular = Nothing
Medium = Nothing
SemiBold = Nothing
Bold = Bold of Regular
ExtraBold = Nothing

Light Italic = Italic of Light
Regular Italic = Italic of Regular
Medium Italic = Italic of Medium
SemiBold Italic = Italic of SemiBold
Bold Italic = Bold and Italic of Regular
ExtraBold Italic = Italic of ExtraBold


Should be fine. Can you send me the .glyphs file(s)?

Hi there!
Did you figure this out by any chance?
I’m coming across a similar problem (I don’t have Italics though).
And I confirm it happens only with TTF files.
Comparing TTFs and OTFs head, OS/2 and name table, I don’t see relevant differences (OS/2 and name table are identical). Cheers!