styleMapFamilyName windows bug

My exported TTFs are showing up with the wrong style names on windows. The instance Style Name is set to “Regular”, the weight to “Regular” (even panose is Regular) but when I open the exported TTF in Glyphs it shows the styleMapFamilyName is “Light”. How is that possible?

Presumably I can hard set this with my own custom param but it shouldn’t be necessary right?

Do you have any custom parameters in the font or instance settings?

In which app?

In the font installation app.

Only panose instance settings.

If you do not set Panose, does it work as expected? You can disable it by adding an x to the custom parameter name.

Same result unfortunately.

I would look into the OpenType tables, especially the name and OS/2 tables, and see if there is anything wrong with the export. Best to do so with FontTableViewer (from the Tools section of this page).

If not, then you may have discovered a Windows bug, or perhaps it was just a font conflict. Perhaps try a different family name, etc.

If the table is somehow not OK, let us know which entry was written out wrongly, or send us the file.

The issue can only originate from Glyphs on my Mac. When I open the exported TTF in Glyphs it clearly has the wrong style map name set. This happens with two different family names incidentally. Opened TTF:

This all happens when styles are linked.

Is the screenshot from the original .glyphs file?

no - that is the exported TTF opened up in Glyphs confirming what I was seeing in Windows. Ie. Thin instead of Light.

What does the info of the original .glyphs file looks like?

It just had panose parameter and all styles were linked.

How were they linked? As advised in the Naming tutorial?


Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

You know what looking through the files the styles were linked in more than 4 styles :expressionless:

My bad.

1 Like