Stylistic alternatives error

I am trying to get a stylistic alternative set to work but I keep getting the same error even after a thorough trouble-shoot:

Error: “syntax error at “t_five_F.ss02” [features.fea 36” in Class LIGATURE in line: 3

Maybe somebody sees the issue.

You have to use substitution rules, as in:

sub A by A.ss01;

Yours would look different, of course. Read the tutorial, here:

and here:

No, i m substituting whole classes (see classes on the photos above) and telling it do so in my features here:

like so:

But when I fill in my classes and click on update to make sure everything is allright I get the error (Error: “syntax error at “t_five_F.ss02” [features.fea 36” in Class LIGATURE in line: 3) as mentioned above. I also deleted the ligature that gives an error but then i get the same error of another glyph (r_five_F.ss02)

Sorry, I failed to look at your panel on the left in the first post, so my reply was not appropriate to solving your problem.

Could the error happen because you don’t have the same number or glyphs on both classes?

it is the same amount of glyphs :confused:

Are you sure? Judging by the screenshots, I can see the LIGATURE2 class has 6 more glyphs than the other one.

Anyways, if the error points to a certain glyph, the culprit usually is the glyph immediately before it on the list. Make sure the glyph exists on your font and it is set to export.

Could be either an invisible character at the end, or a typo in the previous glyph name. Very often, when the afdko reports an error at a certain spot, the error lies in what comes immediately before it.

Edit: sorry @harbortype, had started my reply yesterday and not seen yours when I hit the post button.