Stylistic set confusion

Working on a font where I have more than one version of a few glyphs so I’m adding a stylistic set.

I’ve named the glyphs a.ss01 etc (following the post on stylistic sets).
I let glyphs build the feature code for me by cmd I / featrures / update.

It works perfectly for the first glyph, but when it comes to the second (or more) I get confused. It seems to only want to do it for one glyph. When I update nothing changes and the stylistic set seem to only contain one glyph.

I tried a noob version of just writing the same code myself by switching letters (sub b by b.ss01) but it just switched from the first to the second glyph, not adding it.
And when I try to add so I have both (1. sub a by a.ss01 2. sub b by b.ss01) It tells me I’m doing it wrong.

I’m new to stylistic sets in Glyphs and I’m sure I’m doing something silly, the only problem is I don’t know what that silly is.

Here is a demo file of how stylistic set should work:
Demo.glyphs (6.5 KB)

All glyphs with the suffix .ssXX are part of the set XX (e.g. 01, 02, …).



Strangely that’s how I’ve done it.
Or at least it’s what I tried to achieve. I’ll try it again.

Yup, I was silly. Saw the warnings (lil red stop sign) and never clicked update.
Got it right now. Appreciate your help!

1 Like