Subsetting upon export?

I just delivered a subsetted font. I made it manually, because it seemed whatever I did didn’t work out properly.

What would be the easiest and less problematic way to generate a subsetted font from Glyphs? Step-by-step?

add a “Remove Glyphs” or “Keep Glyphs” custom parameter. You might need to add a “Remove Feature” parameter for features that are not calculated automatically.

Each time I use ”keep glyphs” on an instance, the exported font is corrupt afterwards, and can not be opened.

Can you send me the .glyphs file?

It’s the same on every document. I just made a font with just squares, same problem. Please download it below. Am I entering the glyphs to be kept in a wrong way?

I am on Glyphs 2.0.1 (727)

You have to enter one glyph name per line. Your font ended up without glyphs because it tried to only keep a glyph called A B C, which doesn’t exist, of course. And, but that was not the problem here, do not forget about space and .notdef:

1 Like

Thanks. It worked. There was a new problem arriving now.

This is a error message that tells you exactly what to do. (Hint: you need a custom parameter to fix it)

Sorry, I don’t think it’s very clear what to do.

  1. Which documentation should I look at?
  2. How should I use “option `–symbol’. ?

I’m going to guess that @GeorgSeifert is referring to the:

TTFAutohint options

custom parameters in the Instances section. You can also set TTFStems in the Masters section. Click on the value side. The TTFAutohint options will show a pop-up of options one can set.


that is not related to ttfautohint but to the manual TT hinting.

I couldn’t find a “Remove Class” custom parameter. I have used “Remove Glyphs”, but upon export I get an error message telling me some classes have glyphs “not in font”.

I’ll add a ‘Remove Classes’ parameter.