Substitute long string with PUA glyph in Discretionary Ligatures


#1
sub space c h i c k e n space d i n n e r space by uniE0B5;

What’s wrong with this? Doesn’t do anything in Indesign with the dlig feature on. If I insert the uniE0B5 from Indesigns glyph palette, it actually inserts the text “chicken dinner” instead. Does it matter if the target glyph is in PUA?


#2

The space as part of OpenType features is tricky. Indesign is using a different character instead of the space and that something breaks code like this.


#3

Oh. This wasn’t the case before, I remember this line has worked just fine a couple of years ago. I’ll try without spaces then. Thanks Georg!


#4

sub c h i c k e n d i n n e r by uniE0B5;

Removed spaces but doesn’t make a difference. Tried with long strings and shorter ones. It just won’t substitute with dlig on in Indesign.


#5

Are you sure you don’t have a font cache problem?


#6

I use a proper font manager, removed old versions and used a different family name. I’m sure it is not a cache issue.


#7
  1. Don’t use a font manager. That is begging for problems. Use the Adobe Fonts folder instead:
    http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps
  2. It may also be related to the Composer you are using. Try switching to the Worldready Composer.
  3. Still a bad idea to include space like this. It will not work in some situations.

#8

World-Ready Composer, that was it. Thanks Rainer!