Sudden change of leading in one style

During development I exported more than 50 versions of the font and everything was fine. Now suddenly one of the instances has double the line height. Metrics weren’t changed.

Where are you testing the font?

Fontbook and Font Case.

I extracted the oldest backup available from Time Machine dated February 8th. Still the same problem: five weights, the darkest one has 2x leading.

I even exported the .otf’s with the older version of trial (1.3.9) I have from before - still the same problem. WTF?

Can you send me the .glyphs and the .otf files?

Are you renaming the font when you export it? You could run into cache troubles otherwise.

Yes, I make unique name every time.

You know you can set vertical metrics directly:

I checked the font files and they where fine. This is probably a font cache problem.

I’ll try resetting it then.

EDIT: Nope.

Still sounds like a bad cache problem. Try uninstalling then font and then cleaning out every system cache by running Applejack ( Then reboot, and do not reinstall the font. Instead, just put the test fonts into ~/library/application support/adobe/fonts and see if it works correctly.

Applejack didn’t help either. There is (never was) no problem with CS or online testers, but how am I supposed to know if bad leading won’t appear in users’ other apps?

This kind of problem only occurs, if you install a different version of the font over and over again. The user will only have only one version and nothing can get confused.

To be sure, use a tool like DTL OTMaster Light to check the metric values in the font.

  1. I always export every new version with new name. No duplicates ever.
  2. Nothing was changed in the masters.
  3. OTMasters shows everything’s OK.
  4. Cleaned cache several times with different methods - nothing.
  5. It affect’s only one instance. I tried setting a different name, different weight - nothing.
  6. I tried setting vertical metrics manually with parameters - nothing.
  7. Tried exporting with different version of the app or from different version of the master file - nothing.

It just came one day out of nowhere. I just don’t understand where’s the problem. It’s computers - something as causeless as this just doesn’t make any sense. It’s crazy…

can you send me the .otf file again?

Can this be the similar problem?

Setting your Vertical Metrics parameters for all masters fixes your problem. Copy this into your clipboard and paste it into the Custom Parameter fields of all Masters:

hheaAscender = 780;
hheaDescender = -220;
hheaLineGap = 100;
TypoAscender = 780;
TypoDescender = 220;
TypoLineGap = 220;
winAscent = 800;
winDescent = 200;

1 Like

It worked, thank you.

For anyone reading this in the future: you actually have to set values according to each master’s metrics.

Not necessarily. If you want the leading consistent across all fonts of the family, I'd recommend to use the same values in all Masters.