@ symbol won't type

I’m using Glyphs Mini and have created two fonts within one font family.

In one font, the @ symbol works fine.

In the other, the @ symbol won’t type outside of Glyphs Mini. While working in Glyphs Mini, it looks exactly as I want it to look. When I export and then use it in Adobe Illustrator, everything works except for the @ symbol. It doesn’t try to replace the font, it just won’t type (ie. hitting Shift-2 results in nothing)

In Glyphs Mini, I’ve tried deleting the @, creating a new one from scratch, and re-export. Still won’t work. I’ve even tried deleting the @, creating a new one with only a primitive square inside, and exporting. That doesn’t work either.

I’m exporting directly to my Adobe font folder so there shouldn’t be any caching problems.

Any suggestions on how to fix this issue?

Sounds like a font conflict. You probably have a font with the same name installed. Try changing the name of the font and export again.


Even if I’m exporting directly into the Adobe font folder? The link above says that so long as I export there I should have no cache problems.

I’ll try it.

Deleting all instances of the font, then re-exporting did not change the issue. I still cannot type an @ symbol

Can you send us the .otf and the .glyphs file?

For this font, the @ should be a number 2 inside a black box. Numbers 1234567890 are numbers and hitting shift-1, shift-2, shift-3, etc will be numbers inside black boxes. All others work except for @ (shift-2)

The font is fine. Are you sure you don’t have an old version sticking around?

Hmm, good to know the font is working. Maybe there is a conflict with the two fonts? I’ll try deleting all instances and clearing my font cache and then only install this version and try again.

Thank you for the help so far and I’ll update if this corrects the issue!

I still cannot type the @ (shift-2 which should render a number 2 in a black box). I’ve deleted all instances of both fonts in my system and Adobe font folders. I’ve deleted my font caches and restarted my computer. Still having this issue.

In Adobe Illustrator, when I hit shift-2, nothing types at all.
In Photoshop, when I hit shift-2 the font changes to whatever font was selected before and I get an error message "Could not complete your request because of a program error."
In InDesign, when I hit shift-2, all previously typed letters collapse on each other into one single block. This is hard to explain as I’ve never seen it before.

Are you on a Mac? Did you install the font using font book or did you put it in the Adobe font folder?

This does not sound like a font problem. If the glyph is missing, you should see a notdef symbol. Consider updating or reinstalling your Adobe apps. Consider also testing with TextPreview (see the Tools section of this website).

I also just tried this in Pages and Text Edit and nothing types when I press shift-2

I’m using the most current versions of Illustrator, Photoshop and InDesign.

I installed TextPreview, set my Preferences to a folder with the font, selected the font, and nothing happens when I press shift-2

I’m going to try creating a new file in Glyphs Mini, created only the @ and export to see if that does anything.

I created a new file in Glyphs and cut and pasted the @ from my problematic Glyphs file to the new Glyphs file, exported and the same problem occurs in TextPreview. When I press shift-2 nothing happens.

Are you sure you have the right keyboard layout? Perhaps Shift-2 is rerouted? Does it work with other fonts?

If the font didn’t have an @ sign, it would fall back to another font in TextPreview. If not even the cursor moves, I’d think there is something else wrong. Try this: in after you typed @@@ in TextPreview, select all, copy, and paste into UnicodeChecker, Utilities Window (Cmd-2) > Split Up. Does it show this:

Then the most plausible explanation is that in the font you were trying, the @ glyph was empty and zero width. If nothing shows up, have a look at your keyboard layout.

Try exporting the font with a different family name, and try again. If it works then, it was a font conflict.

I can type an @ symbol by pressing shift-2 with other fonts.

Am trying your suggestion using UnicodeChecker now! Will also try exporting with a different family name.

Thanks again for your assistance!

As you mentioned, in TextPreview, hitting shift-2 results in the cursor not moving. But I selected all and then pasted into UnicodeChecker and it shows up exactly as your screenshot.

I’ve exported with a different family name with the same results in TextPreview and UnicodeChecker.

I even deleted the @ in my font’s Glyphs Mini file, recreated the letterform in Illustrator, created a new blank @ and pasted the shape into Glyphs, exported, with the same results :frowning:

I have uploaded these new Glyph file and OTF here:


I also tried testing the OTF using TextPreview on an older Macbook Pro laptop and it has the same issue. The cursor does not move when pressing shift-2.

Sorry that it took so long. I finally can reproduce the problem. I have a look.

I just uploaded a new version. Can you please activate cutting edge versions (in Preferences > Update)?

1 Like

I was using Glyphs Mini which didn’t have an update, but I downloaded the trial of Glyphs and updated that. Opened the file and exported.

It works! I tested this in TextPreview, Adobe Illustrator, Photoshop and InDesign.

Thank you very much for your help! This was very frustrating and you guys really came through :slight_smile:

Did you install Glyphs Mini from the Apple AppStore? Then the upate will take longer, I am afraid. :frowning: