Text editor cursor inserts glyph in wrong place

Apologies if this is a known bug (tried searching but couldn’t find exactly the same issue) but I have had this issue inconsistently almost since the beginning of using Glyphs 3 in many different glyphs files and it’s becoming increasingly frustrating. Currently on latest stable 3.1 (3133).

Basically, at a certain point in a tab with just a few or many glyphs, the cursor insertion point breaks down and even if it appears to be, say, at the end of the line, if I insert a new character or delete, it will take place at a seemingly random point in the text. It makes working with text samples basically impossible.

It’s quite hard to display without a screen recording (I see video files are not allowed here. Let me know if I should upload somewhere else for reference).

Gosh, that sounds extremely odd. Indeed a screen recording would be very helpful. You can either upload a gif (if it’s not too long) or paste a link to a third-party hosting service such as Vimeo where you upload your recording.

It’s quite hard to illustrate without saying what keys I’m pressing but at no point in this gif am I pressing delete or moving the cursor to the beginning of the text. I’m only pressing return (which sometimes deletes the last glyph) to try to add characters to the end of the line

This is indeed most peculiar. Do you have any third-party apps controlling input? Have you tried a completely fresh install of Glyphs 3? This is an issue I have never heard of. Do you have any special settings concerning typing direction (bottom right in the preview panel)?

What is the Unicode of that icon? It might be because it has a upper plane Unicode that uses two bytes in the 16 bit string implementation that is used for strings in objC. And that extra byte at the end confuses the input. Try inserting the icon before the last char?

Interesting! I understand none of that technical reasoning :rofl: but in the case of this specific glyph, it’s the “door” emoji (see attached unicode info)
Screenshot 2022-09-01 at 09.33.47

But I really doubt that it’s something relating specifically to this glyph — as I mentioned I’ve experienced this issue over the past couple of years intermittently while using Glyphs, in various different files. I assumed it was a long running bug that was possibly related to cutting edge versions, but have since reinstalled the latest stable release to see if that fixed it.

It is certainly not just occurring with icons, but regular text glyphs too.

I should say also that I have quite a few plugins installed, so maybe something is going wrong there (including most of the Mark2Mark plugins). I fear you will suggest a completely clean install and add plugins one by one :sweat_smile:

And by the way @SCarewe, no there are no 3rd party apps controlling input that I know of. I mean, I use a Wacom but not sure that counts. Also no special settings re: type direction.

I’m not sure if this is related but in my current file (which is admittedly a little overly complex) Glyphs is also not remembering open tabs with type samples after saving and reloading.

However, regarding your suggestion @GeorgSeifert about inserting the icon before the last character instead, that does seem to have slightly more consistent behaviour (i.e. correct) than adding to the end of the line. But this is hard to test as it’s still inconsistent.

My suggestion was not meant as a permanent solution. I’ll look into this and will fix it for good.

Great, thanks!