Text tool canvas in RTL mode


When using the text tool to type some text, the canvas orientation, changes from landscape to portrait,
when switching between LTR and RTL.

So when you type in RTL, the canvas is portrait orientation, which makes it hard to write and test long words…
You can see in the gif that it changes from 2 lines with 2 words each, to 4 lines with just 1 word - not very convenient…

Is it possible to keep it in landscape?
And have a larger canvas for typing?

What size do you have set for the Text View Width in the preferences?

What version do you have?
Can you send me the .glyphs file?

I didn’t notice that there’s an option for Text View Width, so it’s set to 5,500. I’ve changed to 15,000 and it’s better.
But it still changes the width of the text area when switching to RTL.

Version 1.3.19.

could you send me the .glyphs file? I can’t see a problem and it might have to do with the file.

Thanks for the file. It helped me to fix the problem.