The Arabic letters comes separately، Instead of connected,

Hi There, Thank you for the great software!

recently I tried to edit a Arabic font on the Glyphs but when I writing something with the “T” tool on that
the Arabic letters comes separately، Instead of connected,
I tried solve the issue to to used "Align right " to writing and I used Arabic keyboard as well but the issue hasn’t fixed!!

I was wondering how can I solve the issue
thank you very much

Have you tried to switch to right to left mode in the lower right of the edit view?

Yes, I did, But it doesn’t worked !

How are you testing? And what are your positional Alternates called? Are all your features set to automatic?

Can you send me the .glyphs file please to support (at) (this website without www). I will have a look.

Can you send a screenshot of our setup? (Send it via direct message if you can’t share it publicly).

Hi there, thank you for reply quickly
here is the screenshot

Thank you so much

thank you for reply, I will send you the glyphs file to

I was wondering how can I solve the issue
thank you very much

Could you send me your .glyphs file?

I was sent you already !

I cannot find an email from your e-mail address (the one you registered in the forum).

Did you send it to the proper e-mail? support with two p’s

Yes I did! ,But I can send it again Right Now ! to the

the Suport dose not working! I will send you the file glyphs to your email.

I was wondering if you received the file?

Telling from the screenshot you posted: It may have to do with the fact that you opened an existing TTF, rather than a .glyphs file. You need to make sure that the positional variants adhere to the naming convention (.fina, .init and .medi name suffixes), otherwise Glyphs cannot guess the replacements for you.

Perhaps read this tutorial:

I received your file, and it is as I suspected: The font is using custom naming, therefore Glyphs cannot automatically guess the positional alternates. Please follow the advice in the tutorial I posted above.

  1. Disable custom naming in Font Info > Other Settings.
  2. Select all glyphs and update their glyph info (in the Glyph menu).
  3. Delete and update all features in Font Info > Features.

Again, the e-mail address is not suport, but support with two p’s, followed by