The voiced mark of "half-width katakana"



I’m making Japanese Font with Glyphs 2.4.1.

I set the width of all halfwidth character to “500”, including half-width katakana.

Apparently the width of voiced mark (U+FF9E) and semi-voiced sound mark (U+FF9F) always become “0” when I try exporting OTF or TTF, and voiced mark is off to the last character before.

How can I fix this?

The addition glyph “.notdef”, “null”, “CR”, “space” and writing at the top of glyphOrder,
and “generate Feature automatically” has already been completed.
(ROS: Adobe-Identity-0)


Both glyphs are defined as Nonspacing in the GlyphData. That cause the reduction to zero width on export. I’ll review this setting to make sure this is correct. For now, select the two glyphs in font view and press cmd+opt+I and set the Subcategory to Spacing.


The problem is solved by setting the Subcategory.
Thank you so much!!


I also encountered this problem and thanks to this topic I solved it.

I think this is an issue that confuses many Japanese creating half-width kana character.
So, I hope not to change the width to zero for both glyphs (U+FF9E and U+FF9F) by default setting.


I lost sight of this. Thanks for the reminder. I fixed it.