The worst bug of Glyphs Mini 2... IMPOSSIBLE to open and edit the fonts!


Today I purchased the Gylphs Mini 2, with the help of Tim Forssman, but the app is very buggy now.

I opened an open source font with it, it warned me that it is locked and it suggested me to duplicate. I duplicated, but I kept receiving repeatedly the same warning, it duplicated more than 5 times everywhere.

See the screenshot:

Preview the screenshot

Glyphs Mini is turning impossible for me to open the other fonts, because that same warning of locked font always appears like an eternal and locks me every time I open the app. While I kept that warning of the locked font, I tried to open with other fonts, but it trashed and closed. Glyphs Mini with the permanent and eternal warning of locked font no longer allows me to open and edit other fonts. I had to clean Glyphs Mini caches and cookies to remove the font and the warning.

After cleaning the caches and the cookies, I opened the app with a font, it closed and trashed.

Your app is excessively and ubiquitously buggy.

I am really and totally frustrated and deceived with you. I’ve already contacted Tim.

Can you send me the font in question? I’ll have a look.

Can you try turning on cutting edge in Glyphs mini > preferences > updates, and see if the error persists?

Where was the font when you opened it for editing? Was it an installed font, or in use otherwise? I have a suspicion that it still tries to open it for editing. Try disabling the open recent documents option in system preferences > general.

Here is the font:, @GeorgSeifert.


I did before and the error is still the same.

I kept the font in my folder Documents or in my website project’s fonts folder from the user folder.

I disabled, but the warning of a locked font still appeared when I started the app.

OS: macOS Sierra 10.12.6
PC: Mac mini Mid 2011 Core i5 8GB RAM

I updated to and I still received the same warning. It upsets me excessively.

Thank you for the detailed information. We are looking into the issue.

Can you please try the latest cutting edge version (81). It should solve the problem.

Immediate help:

  1. force quit Glyphs Mini 2
  2. in Finder, choose Go > Go to Folder…
  3. paste this in the upcoming dialog:
    ~/Library/Saved Application State/com.schriftgestaltung.GlyphsMini2.savedState
  4. Delete the folder com.schriftgestaltung.GlyphsMini2.savedState
  5. Restart Glyphs Mini 2

And when you open an existing .ttf or .otf file, it is a good idea to hold down the Option key, choose File > Save As… (Cmd-Opt-Shift-S), and thus, save the file in the .glyphs file format right away.

After the update and I opened a OTF or TTF file and added a new glyph, I received the warnng, and clicked in OK, I still received the same warning endlessly, and I clicked in “Save as”, it took more than 3 minutes to save it. I had to force quit.

After following your instructions, when I saved a font as .glyphs file, it crashed and closed. I reopened it and it appeared with a TTF or OTF file instead of .glyphs, and it is still locked.

How do I send the log to you?

I can’t upload a file or i can’t write more than limit of characters.

A dialog should offer to send it when you restart the app:

I cannot reproduce the Save as crash. Did you delete the folder?

I fixed a few more details. Please try version 82.

Sorry for my absence, I had a violent headache and I had to sleep for 36 hours.

Yes, I did. I have just sent, @GeorgSeifert and @mekkablue.

I tested, I saved as a .glyphs file and it worked. But when I open a locked font OTF and I added a new glyph, the warning was different: “The operation could not be completed.” After I clicked “OK”, it got unlocked. Nothing crashed, It seemed to work.

1 Like

So you can work with it now? Saving as .glyphs works as well?

Yes, it did. When It saved it as .glyphs, it didn’t crash or closed. It got unlocked.