Toolbar icons changed to text after crash

I had a crash working in Glyphs 2 Version 2.3b (837) and then Glyphs kept crashing on reloading the app. I cleared out all the autosaved files, rebooted my computer in safe mode, and emptied the trash, then the app would load but I couldn’t open any files without Glyphs crashing. So I checked updates manually and installed the Version 2.3b (838) update. Now the files will open but the toolbar icons in the Glyphs window are all changed to text. Did I remove a settings file? How can I restore the toolbar view?

Something is corrupted now. I cannot view the outline placed in the background layer.

Does this appear in another user as well?
Which plugins are installed?

I don’t know about other users. My plugins installed are:

What MacOS do you have?


The missing toolbar icons showing up as text is not a big problem. The background issue is very hindering for my work. I can place an outline in the background (command J) and see it while I’m in the foreground. When I switch to the background (command B) the outline is gone. However there is something there that is not visible or selectable because the Red Arrows are showing up. I am unable to edit the background layer.

I meant testing in another user on your Mac (see system preferences > Users). This is a way to see if a problem is related to user settings or to something system-wide.

Some of the plugins may be outdated. Perhaps try disabling the plugins by renaming the Plugins folder and restarting to app. If that does not help, try redownloading the app from Buy | Glyphs.

I tried to check with my other user account but the Glyphs version has expired and it won’t let me install it over again. I guess I need to set up a new user account to check that. However, I tried downloading the app again. By installing the app again my icons and ability to see the background outline while in the background layer came back. But, lots of my composites got messed up. So I didn’t save the file and checked for upgrades. I upgraded it to the latest (838) and the problems came back but the composites were fixed! It did not help to remove the plugins.

I fixed the toolbar.