Touché Plugin not loading

Hello, wondering if anyone could help me with an issue I’m having with the Touché plugin. In the Macro window I see the following error after installing Touché and restarting:

Traceback (most recent call last):
  File "", line 10, in <module>
  File "", line 5, in _run
base = os.environ['RESOURCEPATH']
  File "", line 23, in __getitem__
raise KeyError(key)
Traceback (most recent call last):
  File "<macro>", line 5, in <module>
UnicodeDecodeError: 'ascii' codec can't decode byte 0xcc in position 123: ordinal not in range(128)

And there is no indication that the plugin is available (searching previous threads, I see it should be in the Edit menu). If I uninstall Touché the error stops appearing.

As directed on the Touché Github page, I have ensured that the latest robofab and vanilla are installed, and objectsGS and GSPen from Glyphs-Scripts are in the root of the Scripts folder. I am on the latest version of Glyphs, 2.6.1.

It seems to work fine for me in the latest version.

The error message seems to be from a different plugin.

Interesting. The Macro window only shows the error when Touché is installed, and other plugins seem to work OK. I will keep troubleshooting. I’m not versed in Python at all, so let me know if you have any suggestions for where to look. Thank you.

Just to add, when I switch output to Console, it specifically states there’s a problem with Touché. Otherwise the info is the same as what was seen in the Macro window.

Problem with Plugin at Path: /Users/[ME]/Library/Application Support/Glyphs/Repositories/Touché/Touche.glyphsPlugin (!PrincipalClass)

On a hunch I changed the folder name from Touché to Touche, removing the e acute character, and the plugin loaded up fine! Since it worked on yours I wonder if it’s something to do with my system being set to U.S. English.

What version of Glyphs do you have?

2.6.1 (1230)

It seem indeed that the plugins can’t have non ascii chars in the name. Very strange. I see if I can work around it.

1 Like

Can you try it now. I think I have fixed it.

New error:
File "/Users/[ME]/Library/Application Support/Glyphs/Repositories/Touché/Touche.glyphsPlugin/Contents/Resources/../MacOS/", line 9 base = os.environ['RESOURCEPATH'] ^ IndentationError: expected an indented block Traceback (most recent call last): File "<macro>", line 5, in <module> UnicodeDecodeError: 'ascii' codec can't decode byte 0xcc in position 123: ordinal not in range(128)

Can you try again. There was a merging error.

Jackpot! Working fine now. Thanks so much for your effort.

I’m unable to get the Touché plugin to work. Installed with the Plugin-Manager, restarted – it just doesn’t appear in the edit-menu or anywhere else. and is installed. word-o-mat is working, but Touche … :frowning:
Then I downloaded the files from

but don’t know where to put all this stuff – if necessary

The macro-window shows me some lines about the wordfinder-plugin, but nothing that seems to be related to Touché. Glyphs is 2.6.6/1348

I found a bug, will issue a pull request in a minute.

Update: Done. You can un- and reinstall the plug-in after Georg merged my Pull Request. (May take another hour or so, sorry for the inconvenience.)


Great! Now it works!