Trace Image Filter Does not work

I installed the Trace Image plug in and placed an image into a glyph window. When I select the image trace filter, nothing happens. I’ve played with the perimeters in the dialogue box and still no trace. Can anyone tell me what I’m doing wrong?

Looks like the plug-in needs an update. It is currently broken.

OK, thanks. I guess I’ll have to use the rather inadequate Photoshop path creator or the trace tool in Illustrator. Both of which I was trying to avoid. At least I know it isn’t me. :slight_smile:

Any chance there will be a fix to this issue any time soon?


Not before next week. Sorry, cannot give a more precise date.

Workaround: The plug-in still works in Glyphs 2, so you could set up the document there, run the filter, and then bring it back to Glyphs 3.

Doesn’t work for me as well… not even in Glyphs 2
Getting “No Result” everytime.
Latest updates to Glyphs and MacOS 11.2.3 if that helps.

if you don’t mind spending a few bucks, I’ve had good results with this. ‎Image Vectorizer on the Mac App Store

1 Like

I may not have appropriately thanked those who have responded to help me with this. So, even though I haven’t had a chance to work through it and figure it out, I just wanted to say thank you for trying to help.

I uploaded a new version. You might need to remove/re-install it from the Plugin Manager.

Now it looks like it traces the image bounding box, tried few image formats but no luck:

Screen Recording 2021-05-26 at 11_24_19

the Autotrace has an option to ignore the white background. But if I set that, it doesn’t do anything for me at all. But it did trace the back and white shape as two shapes. Can you send me that image?

I’m encountering the same problem with Big Sur 11.4 + Glyphs 2.6.6 (1352).

I built the GlyphsTracePlugin by myself and checked it out. And I found the Result was unexpected one, i.e. “(\n)\n” at TraceImage.m#L123 when using Potrace. Specifically write_paths did not write anything out at backend_Glyphs.c#L195.

This led me to wonder if the bitmap file was not being saved properly around TraceImage.m#L105-L114 and wrote the following snippet and ran it in the Macro Panel with selecting only one glyph.

import os

class NSBitmapImageFileType:
	NSBitmapImageFileTypeTIFF, NSBitmapImageFileTypeBMP, NSBitmapImageFileTypeGIF, NSBitmapImageFileTypeJPEG, NSBitmapImageFileTypePNG = range(5)

def save_to(file_name):
    return os.path.join(os.getenv('HOME'), file_name)

type2file = {
    NSBitmapImageFileType.NSBitmapImageFileTypeTIFF: save_to('backgroundImage.tiff'),
    NSBitmapImageFileType.NSBitmapImageFileTypeBMP: save_to('backgroundImage.bmp'),
    NSBitmapImageFileType.NSBitmapImageFileTypeGIF: save_to('backgroundImage.gif'),
    NSBitmapImageFileType.NSBitmapImageFileTypeJPEG: save_to('backgroundImage.jpg'),
    NSBitmapImageFileType.NSBitmapImageFileTypePNG: save_to('backgroundImage.png'),

layer = Glyphs.font.selectedLayers[0]
image = layer.backgroundImage
bitmap = image.image.flatImageRep()
for type, out_path in type2file.items():
    bmp_data = bitmap.representationUsingType_properties_(type, None)
    bmp_data.writeToFile_atomically_(out_path, False)

As a result, a white image was generated only when NSBitmapImageFileTypeBMP was used. I was convinced why potrace could not generate outlines, but I do not know the root cause. It may be a problem specific to my environment…

I just tried it today for the first time and I have the exact same problem.
I use Glyphs 3 in macOS Catalina. My embeded image files are TIFF.

Yeah I wasn’t able to find any Auto Trace Functionality in Glyphs either, Its a nice app, but I will stick with FontLab 8 since it has auto trace (Element>Image>Auto Trace) and it works great! hopefully this app gets a built in auto trace since Glyphs actually runs so smooth and is made for apple silicon and doesn’t crash like other font apps.

Actually, in Glyphs 3, you can add the Plug In for auto-trace, and it works fine.