Trouble with OTF feature replacing a character among a specific string

I’m trying to replace a colon that follows a number with an alternate colon.ss01 character, but something is obviously wrong in my code, because it’s not working.

@num = zero one two three four five six seven eight nine
sub @num colon' @num by colon.ss01;

Not sure where I’ve gone wrong. Everything compiles and the OTF files successfully export without error, just no replacement in any working versions of the typeface.

How did you define num? In the sidebar or inside the code? If the latter, you have to surround it with brackets and end the line with a semicolon.

And in which feature did you place it? And in which app are you testing? Are you using the Adobe Fonts folder?

@num was defined as a stand-alone Class in the Features panel. I also tried it without using a Class, without success.

sub [zero one two three four five six seven eight nine ] colon' [zero one two three four five six seven eight nine ] by colon.ss01;

I’ve been testing on a specimen file in InDesign. As for the location of the OTF files being used in-app, I run FontExplorer X Pro, which currently places activated fonts in a “FontExplorer X” folding in my User folder. Would the location of the OTF file affect things?

The feature code seems OK to me. In which feature did you place the code?

Do NOT install your font until it is finished, also not with FontExplorer. Rather, use the Adobe Fonts folder. This time, please rename your font beforehand in order to exclude cache problems.

Currently, it’s in the calc Feature.

Wouldn’t I be able to see the replacement happening in Glyphs in a tab along side other characters? It’s not happening right now either, like the Advanced Alternatives tutorial suggests.

Put it in calt, not calc, press the compile button in the features, and activate it in the edit tab.