Troubles with updating / reinstalling / download link not working

I’ve been experiencing very odd crashes lately, so I decided to do the usual routine - check the updates for the latest version of glyphs, and possibly reinstall the app.
But when i try to update it prints out an error (Update Error! An error occurred in retrieving update information. Please try again later.)

and the link ( is broken…

Any ideas?

The download works fine for me. Can you try again?

Do you have any maintenance tools like MacCleaner installed? If so: It is actually malware, please get rid of it.

Hm… Tried to download it from another computer - it worked.
I had CleanMyMac (which isn’t problematic i think?), uninstalled it, scanned my computer with three different antivirus programs, found nothing.
Installing modules also doesn’t work… It’s like if the firewall was blocking the connection, or my ip was blacklisted?

CleanMyMac is the problem. It has a function that pretends to manage your apps for you, but actually messes up a few things and can break app functionality.

I cannot think of a scenario where anyone would profit from the use of such tools on a Mac. My advice: get rid of all these maintenance and antivirus apps. All they can possibly do is break things.

1 Like

Thank you a lot!:slight_smile:
After cleaning my mac of cleanmymac and scanning it several times with different anti-malware sw i found out that something was blocking Glyphs from accessing the internet.
I find this whole situation very odd, because im using a licensed app, and this seems like a thing pirated sw would do :man_shrugging:
Im still having problems with installing python modules from preferences, but as i see that’s fairly common thing so i’ll just install them manually.

The python module installation is fixed in the latest cutting edge version.

1 Like