TrueType Hinting bug — ppm shift with Deltas

When hinting in most recent versions of Glyphs, a delta added to 11ppm might apply to 10ppm. I was able to set some deltas properly in version 3.0.5, but the bug comes in regularly.
Going out and back in to TT hinting, can solve the issue for a while.

Also, in most recent versions. When selecting Regular in the preview, the checkmark jumps up one weight. (in this case to Light). This might be related. It only happens in TT mode.

Can you send me a font that shows this? I just tried it and it seems to work for my test font.

The font is confidential. I’ve signed a salty NDA.

I tested another font, and it does not happen.

The preview menu glitch is still happening.
See video enclosed. But it seems not related.
Even though it is a similar glitch.

What upm do you use? Are there any transformations in the instance settings?

Could you remove all glyphs except of the hyphen? And remove all names from font info? That way you might be able to send the font?

The instance pop up is fixed. Will be in the next update.

I’ve sent you two files via email, that still show the issues.
Thanks a lot for the fast reaction.

Found the problem and fixed it. Thanks for the file.