TrueType manual hinting and very black master

I have problem with a very black master. If manually hinted with only stem hints, the e turns completely black.

If I use a shift hint only in the black master, everything looks much better, but is this “legal”? Or are there other ways to manage this?

phhh. Not helpful. This makes the e higher than the o…

My educated guess: maybe you need an interpolation instruction

I have tried already, but the result is not as expected…
Strange thing, because in the a, it works much better

Maybe defining TTFStems globally and applying to the glyph-level stem will help.

Or waiting for a professional to answer your threat :joy:

Can you send me the file?

I would try a triple hint

Check if you have an horizontal stem that would fit the outline of the e. Or don’t use stems at all in the e.

I have created stems only for the e. This is better, but not really good. And it would end in creating lots of stems because in my black design, lots of characters use different stem heights.

(triple hint is set, Interpolation, too.)

Using no hints at all is ok, but shifts up the x-height of the e in many sizes in all instances.

This could be prevented with using only snap points on the extremes, but the result is bad in regular.

And not to forget the Hairline. No matter, what setting, its always a mess.

Best is no hints, but then the x-height is too high.

I meant to us stem hints that do not link to a stem. Add the (purple) hint, and select “no stem” from the info box.