.ttf export issues, languagesystem error (Kannada font)

Hi there!
First, I should shamefully announce that I had been working on my project in RoboFont for most of its development. Hopefully you’ll still be able to/want to help me! :smile: I have a license, I swear! :slight_smile:

I’ve been working on some open source Indic fonts for Google Web Fonts based on ITF’s open source sample code. This particular project is Kannada, based on Mysuru’s feature code.

I had to alter the Mysuru code a bit in order to generate .otfs in RoboFont, which I’ve been doing successfully for a while now for testing. But, I’ve been unable to generate working .ttf files from RoboFont, as is. I was advised to try to bring my project into Glyphs and export .ttf files from there.

BTW, Here is a copy of the .ufo to open in Glyphs, as I want to keep it separate just in case something goes wrong.

Unfortunately, the generation process doesn’t get very far before an error occurs…

Error: "The languagesystem DFLT dflt; statement must preceed all other language system statements." in Feature file at line:4
Error: "not found" in Feature file at line: 8

Which puzzles me, since this is what the beginning of the feature code looks like:

languagesystem DFLT dflt;
languagesystem knd2 dflt;
languagesystem knda dflt;
# include (../../features/GENERATED_classes.fea);
include (features/extension.fea);
#include (features/tables.fea);
include (features/lookups.fea);
# -------------------

Would anyone like to take a stab at getting this to work? Or explain to me what I might do to get this to work? I should probably just get in touch with the ITF people and hire them to help me figure this out, but if you’re willing to help, that would be educational!


Could you send me the font file? Then I have a look.

There seem to be at least a couple issues:

  1. The features.fea file includes some files from the features directory that aren’t included. I haven’t tried using the include feature of AFDKO feature files within Glyphs, yet.

  2. Some of the features have nothing but a comment or blank in them.

For item 2, in the Features tab Font Info (Command-I), I set the blank features to be disabled.

For item 1, I did the following:

  • Attempted an export that fails (to get the Temp directory created).
  • Copied the features/ directory in your repository to the Temp directory: ~/Library/Application Support/Glyphs/Temp/Hubballi-Regular/
  • Attempted the export again and it seemed to work.

My actual steps may have varied, but hopefully that should get you to a spot that might work. I have not tested the resultant .ttf.

Hope that helps some. Perhaps there are better ways within Glyphs to handle some of what is being attempted, but we’d need to look into it further.

I agree with @composerjk, because Glyphs is going to invoke AFDKO in ~/Library/Application Support/Glyphs/Temp/<postscript-FontName>/ you should either add that path to your feature definition or try to export the font without any feature and place you feature in the temporal folder and compile the OT feature file from there .

Ooh, I am learning a lot! Thanks so very very much, @composerjk and @Nicolas – I will try this and let you know how it goes.

Erin, Padyakke builds from Glyphs, so you should be able to look at it and figure out what to do. Just make sure to change your mark categories and subcategories to mark, spacing (cmd+opt+i)

@DunwichTypeFounders James!! Wow, I just recreated my features based on what you had, and it worked!! Wow. I had to delete the Languagesystems prefix area and remake it, it seemed to be the key - ghosts, I guess.

THANK YOU SO MUCH! And YAY GLYPHS!!! YAY .TTFS! And YAY to Glyphs forums for being here! I’m way too happy about this. :smile: