TTH overshooting suppression

I had set TTFOvershootSuppressionBelowPP = 65, but it didn’t work

‘O’ hints:

Result on 64 px size:

What should I do to make overshooting suppression work?

You don’t need the anchor before the stem. If you do the stems, the anchoring is implicit. The stems do start in the zones and point out of the zones, right?

I know, but I think that’s a bad practice. It would be much better if an anchor was set automatically and was visible after using a stem.

Yes, they do. Top O = 710, bottom O = -10 and point to center with width 35.

Does ‘TTFOvershootSuppressionBelowPP’ work with pixels? Mayby there is some problem with dpi?

Is her a reason you set the stem to ‘A’? That is only intended to be used with stems that are not attached to a zone.

I have understood that it works like ResHints (ResYLink for a stem) in VTT from the pop-up description, nope?
Then where can I read about it?

All stems are ResHints. Tr only way to prevent that is to use the rounding options. So just keep them as not rounded.
The ‘A’ option is useful for the middle stems in ‘E’ and ‘e’, mostly in combination with a interpolation.

Ok, thanks for advice. But my problem is not with stems)

But the ‘A’ is deciding the position of the whole stem, basically ignoring the anchor and the zone.

It worked with the top, but the bottom is still overshooting

What version of Glyphs do you have?

And can you send me the .glyphs file?

Version 2.6.1 (1230)

Sent in pm

There was a small issue with the zone detection code. For now, set the bottom zone size to ‘-12’.

It works. Thanks. :crab: