Typeface doesn't show up when exporting?


I exported my font as an otf document, and it says it was successfully exported. However, it did not show my punctuation or symbols they appear as ? with a box around it in Font Book. I tried using the font in illustrator but it shows up blank. Like the letters are being typed out but I cannot see anything.I am not sure what I did wrong. I did try clearing caches too.

This is probably a cache problem. Do NOT install a font in Font Book until it is finished. Why are you not using the Adobe Fonts folder?

How? Here is some additional info about caches:

What if I have more than 1 adobe folder? I looked through them all and don’t know where to add my font folder. I also followed the steps to clear caches but got stuck at the step where I go to the Scripts bar in the top right corner and do Clear Font Caches…there wasn’t an option for me to do that. It only had other folders or the Open Scripts Folder or Open Scripts Editor.

I apologize I am new to Glyphs and am using it for school and the tutorials I have seen didn’t give me the right steps.

Then choose open scripts folder (submenu user) and place your applescript there. Then it is always available.

Which Adobe folder? Only this one please:

/Library/Application Support/Adobe/Fonts/

You can paste paths that are specified like this into the Go > Go to Folder dialog (Cmd-Shift-G).

The tutorial describes how you create and install your applescript there. You can do it with the terminal commands as well. They do the same thing.

I have Open Scripts folder >

-Open Chrome Scripts folder
-Open User Scripts Folder
-Open Computer Scripts Folder

and there are more folder from there. I see a Scripts folder in my library but then there are 8 more folders inside there. I am still confused where I have to paste the Applescript.

I went to Library>Application Support>Adobe>

but then I do not have a Fonts folder in there. Only Fonts Recommended and Fonts Required.

I also tried searching Fonts in the search bar under Adobe, but there are tons of files and 3 different folders titled fonts in there. I don’t know which one is the correct one.

Just add the missing Fonts folder and restart the Adobe apps.

1 Like

@elana_marie please read the tutorials carefully. What you are asking is answered there.

This is where you put the AppleScript.

UPDATE: I just updated the tutorial. I hope that the creating and saving the AppleScript is clearer now.

1 Like

Thank you! its working now