UFO postscriptFontName should not contain spaces

I just tried to export a font (let’s call it "Foo Bar’) to UFO which does not have a postscriptFontName specified. Glyphs added a postscriptFontName to fontinfo.plist in the form “Foo Bar-Regular”. The space between “Foo” and “Bar” causes makeotf and friends to give unhelpful errors.

That should only happen if you have no instances. I fixed it.

Is it only fixed for exporting as UFO? I just ran into this when opening a UFO that was generated with glyphs2ufo. I opened in Glyphs and did a couple things and then when I save it adds the postscriptFontName with spaces. Then fontmake will generate the font, but the CFF is invalid because of the space in the name.

Can you send me that .ufo (the one from glyphs2ufo) and the .glyphs file?

It seems fine in Glyphs 3 beta, but not 2.6.6.

1 Like

Can you send me a .glyphs file that doesn’t export correctly in Glyphs 2?

I didn’t export a Glyphs file. I opened a UFO and then saved it. This one: https://github.com/googlefonts/noto-source/tree/master/src/NotoSansMarchen/NotoSansMarchen-Regular.ufo