UnderlinePosition not working

Hi guys,

2.6.6 (1348), UnderlinePosition parameter is not doing anything. It just exports -75 no matter what.

Works for me. It should be lowercase: underlineThickness and underlinePosition

I just use the parameter and it is in lowercase. Tried it with another file and it still just exports -75 only.

Where did you put it? It should be in the master settings.

and in the post table the numbers mean something else then in the CFF table. One is measuring from the middle, the other from the top of the underline. And Glyphs adjust for this.

Tried both in the Instances as well as the Masters. Still -75.

What value are you using? Can you send me the file?

Note that Georg meant the initial U should be lowercase. The Thickness and Position parts have a capital T and P.

That’s irrelevant. The name of the parameter is preset.


If you use an underline position of -100, the default thickness will be 50. And the makeOTF put the value as is in the CFF table and offset the value in the post table by half the width.

Shouldn’t the values be respected instead of calculated? When I add add Underline Position I feel it makes more sense to get the actual position that I set, instead of having to do math.

Like if I want my final values to be -100 and 50 I should just have to put underlinePosition=-100 and underlineThickness=50. The way it works right now, I have to do the math myself and if I want the same final values go for -125 and 50. It kind of makes no sense.

The problem is that there are two places that store the value with different definition.

I am talking about the app, Glyphs itself. Can’t you make it so that the app calculates the values so that the end result it what the user puts in the custom parameters?