Undo not working after using knife


#1

Working with the last update (the one that fixed undo problem) I’ve experienced a problem with this action. After using the knife (not sure if this is relevant) I couldn’t make undo.

Hope this is useful to solve the problem.


#2

Can you make a screencast of what you are doing. Maybe that helps me to reproduce the problem.


#3

Here you have, Georg. I also replied in another post about a thing going on with knife tool and I’m showing it in the video as well. Once you cut a path one side becomes open. Hope this help

Thanks!

GlyphsKnifeUndo.mov.zip (1.3 MB)


#4

Thanks I hope I fixed it.

But the undo was fine for me. So that might be a different problem.


#5

Thanks, Georg. Could the undo problem be related to using corner components? For now it is the only thing it comes to my mind.


#6

You are right. The undo problem is because of the corners. Thanks for reporting this.


#7

You are very welcome. I’m glad that helped.


#8

And I think I fixed it.


#9

Hi guys! I think I’m having the same issue—not sure why it’s not fixed for me. Please see the short video here. It seemed easier/faster to explain that way. Couldn’t attach the video because it was a little too big.

Currently using Glyphs 2.6.1 (1230)

As always, thanks for your consideration! :slight_smile:


#10

Have you tried 1237?


#11

@mekkablue Ah, that did the trick indeed—thank you so much!